These are some quick notes from installing Linux, specifically Ubuntu Netbook Remix 10.10, on the Asus 900AX.

The 900AX is a throwback to the original eee pc 701. Side by side, they look nearly identical – the 900 just has a 9″ screen, different keyboard labels and 2 USB ports (not 3.) There are a few other budget concessions, for example the RAM is apparently soldered directly on the board instead of on a removable DIMM.

This is offset by the fact I picked it up for just $198AU on sale. It boggles my mind that you can walk into a store and buy a fully functioning brand name laptop computer, new with a warranty, for $200.

Installation

First build your USB stick. You can either do it the easy way as described by Ubuntu, or mess around with dd if you’re keen (I went for the easy way.) Once the USB stick is inserted, boot up and press F2 to get to the BIOS menu. With the USB stick inserted, there will be a “Hard Disk Drives” menu (under Boot) which will let you choose the USB stick as your boot device of choice.

For some reason the trackpad didn’t work the first time I booted the installer (it worked on subsequent boots.) Apart from that, the Ubuntu Netbook Remix 10.10 installation went smoothly. Until the system froze when restarting after installation.

The freezing problem persisted, with freezing/lockups on shutdown, restart, suspend or hibernate. The RT3090 wireless was the problem. To fix it, you can install the DKMS kernel module package containing ralink’s proprietary source drivers. I just downloaded the prebuilt DKMS package on that page, I didn’t build it myself (lazy!) Then I blacklisted the OSS ralink modules:

Appending to /etc/modprobe.d/blacklist.conf

# blacklist other Ralink modules in favour of 3090 DKMS mod
blacklist rt2860sta
blacklist rt2870sta
blacklist rt2800pci
blacklist rt2800usb
blacklist rt2x00lib
blacklist rt2x00pci
blacklist rt2x00usb

Asus at MHV

… fixed! Other than that I’ve only noticed two problems:

  • The brightness hotkeys erratically switch between two brightness settings only, bright & dim. I remember this working properly under Windows in the store, so I’m guessing a driver issue.
  • The battery gets hot when charging, and the plug pack tip gets extremely hot – I almost burned myself on it after an hour of charging & using! Not sure if that’s a common fault or just mine. EDIT: This seems like it was me not properly inserting the plug. Has been fine since.
  • EDIT 2: At one point recently the trackpad totally stopped responding to me. After lots of messing around and wasted effort, I fixed it by shutting down, disconnecting power, removing the battery, and waiting for 30 seconds before powering back up.

Everything else seems to work out of the box so far. Nothing at all like the “bad old days” of Linux hardware support.

If I find anything else useful, I’ll append it here.

6 thoughts on “Ubuntu on Asus eeepc 900AX

  1. Hi!

    Thanks for the informations! I made the same experiences, except your problem with the hot battery. That doesn’t happen with my 900ax, so maybe something with your hardware is wrong.

    Could you find any solution for the brightness hotkeys meanwhile?

    Regards

  2. Thanks Goran! Do you have a webcam? I don’t think I do…

    I haven’t found anything for the brightness hotkeys yet but I’ll post up if I do.

    I’ve charged my 900AX again now, and I think maybe the overheating was because I didn’t seat the charger plug all the way into the socket – it was a little stiff, and maybe I didn’t notice the first time. I hope that’s it.

    – Angus

  3. Yes, my 900ax serie has a webcam (a crappy one, but however).

    I just figured out, that my linux system is not able to work as long as the windows system (and all these asus applications and services) with the carged battery. And I’m not talking about minutes, the windows system works 1 hour longer (basic surfing stuff).

    I also checked if a background service or something could gain the need of energy, but there was nothing special.

  4. 2012 year now and same problems with 900ax (upside down webcam image, weird brightness change). Also 3d apps (games, etc.) is extremely slow, many just not working (Ubuntu 12.04). I’ve tried to reinstall drivers, etc. – doesn’t helps much.
    About longer worktime on Windows – it is because of reduced CPU usage (when auto-performance is on). I think this can be achieved on Linux with some cpu-limiting software (didn’t tried or searched any yet).

Leave a Reply

Your email address will not be published. Required fields are marked *